Parameter |
Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool AllRuleParametersApplicable(
Document aDocument,
ICollection<ElementId> categories,
ElementFilter elementFilter
)
Parameters
- aDocument Document
- The document containing the filter, categories, and parameters involved in this validation.
- categories ICollection ElementId
- The set of categories against which to check the rule parameters.
- elementFilter ElementFilter
- The ElementFilter representing the combination of rules to check.
Return Value
BooleanTrue if all the parameters of the given rules are valid for this filter, otherwise false.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |