Construct a PointOnPlane given a reference and a location in space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
The document containing the plane reference.
- planeReference
- Type: Autodesk.Revit.DBReference
- position
- Type: Autodesk.Revit.DBXYZ
A 3-dimensional position.
- xvec
- Type: Autodesk.Revit.DBXYZ
The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.