Point |
Construct a PointOnPlane given a reference and a location in space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PointOnPlane NewPointOnPlane(
Document doc,
Reference planeReference,
XYZ position,
XYZ xvec
)
Parameters
- doc Document
- The document containing the plane reference.
- planeReference Reference
- position XYZ
- A 3-dimensional position.
- xvec XYZ
- The direction of the point's X-coordinate vector in the plane's coordinates. Optional; default value is the X-coordinate vector of the plane.
Return Value
PointOnPlaneA new PointOnPlane object with 2-dimensional Position, XVec, and Offset properties set to match the given 3-dimensional arguments.