Redraw the circuit table for a template with the given parameter updates
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- newType
- Type: Autodesk.Revit.DB.ElectricalPanelSchedulePhaseLoadType
The new phase load type of the circuit table
- nNumSlots
- Type: SystemInt32
The number of circuit slots
- bPhasesAsCurrents
- Type: SystemBoolean
True if the phase columns should be currents, false if they should be loads
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |