UpdateCircuitTableForTemplate Method


Panel Schedule Data Update Circuit Table For Template Method

Redraw the circuit table for a template with the given parameter updates

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UpdateCircuitTableForTemplate(
	PanelSchedulePhaseLoadType newType,
	int nNumSlots,
	bool bPhasesAsCurrents
)

Parameters

newType PanelSchedulePhaseLoadType
The new phase load type of the circuit table
nNumSlots Int32
The number of circuit slots
bPhasesAsCurrents Boolean
True if the phase columns should be currents, false if they should be loads
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also