Parses a formatted string into a number with units if possible.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- units
- Type: Autodesk.Revit.DBUnits
The units formatting settings, typically obtained from Document.GetUnits().
- specTypeId
- Type: Autodesk.Revit.DBForgeTypeId
Identifier of the target spec for the value.
- stringToParse
- Type: SystemString
The string to parse.
- value
- Type: SystemDouble%
The parsed value. Ignore this value if the function returns false.
Return Value
True if the string can be parsed, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |