TryParse Method (Units, ForgeTypeId, String, Double)


Unit Format Utils Try Parse(Units, Forge Type Id, String, Double ) Method

Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool TryParse(
	Units units,
	ForgeTypeId specTypeId,
	string stringToParse,
	out double value
)

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits() .
specTypeId ForgeTypeId
Identifier of the target spec for the value.
stringToParse String
The string to parse.
value Double
The parsed value. Ignore this value if the function returns false.

Return Value

Boolean
True if the string can be parsed, false otherwise.
Exceptions
Exception Condition
ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId).
ArgumentNullException A non-optional argument was null
See Also