MEPNetworkIterator Constructor (Document, MEPAnalyticalNode, MEPAnalyticalSegment)


Creates an iterator to visit the connected segments on one side of the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public MEPNetworkIterator(
	Document pADoc,
	MEPAnalyticalNode startNode,
	MEPAnalyticalSegment startSegment
)
Visual Basic
Public Sub New ( _
	pADoc As Document, _
	startNode As MEPAnalyticalNode, _
	startSegment As MEPAnalyticalSegment _
)
Visual C++
public:
MEPNetworkIterator(
	Document^ pADoc, 
	MEPAnalyticalNode^ startNode, 
	MEPAnalyticalSegment^ startSegment
)

Parameters

pADoc
Type: Autodesk.Revit.DBDocument
The document of the analytical network.
startNode
Type: Autodesk.Revit.DB.AnalysisMEPAnalyticalNode
The starting analytical node. It must be one of two nodes of the starting segment.
startSegment
Type: Autodesk.Revit.DB.AnalysisMEPAnalyticalSegment
The starting analytical segment to specify the traversing direction from the starting node.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also