MEPNetworkIterator Constructor (Document, MEPAnalyticalNode, MEPAnalyticalSegment)


MEPNetwork Iterator(Document, MEPAnalytical Node, MEPAnalytical Segment) Constructor

Creates an iterator to visit the connected segments on one side of the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MEPNetworkIterator(
	Document pADoc,
	MEPAnalyticalNode startNode,
	MEPAnalyticalSegment startSegment
)

Parameters

pADoc Document
The document of the analytical network.
startNode MEPAnalyticalNode
The starting analytical node. It must be one of two nodes of the starting segment.
startSegment MEPAnalyticalSegment
The starting analytical segment to specify the traversing direction from the starting node.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also