Gets the expanded map of the external resource references referenced
by the element.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since:
2023
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The expanded map of the external resource references referenced by the element.Remarks
The value includes all external resource references under the type.
Use this API for an element which has multiple external resource references
under a specified type, e.g., AppearanceAssetElement.
See also:
[!:Autodesk::Revit::DB::Element::getExternalResourceReferences]
.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | This Element does not use any external resource. |