Element Get |
Gets the expanded map of the external resource references referenced by the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public IDictionary<ExternalResourceType, IList<ExternalResourceReference>> GetExternalResourceReferencesExpanded()
Return Value
IDictionary ExternalResourceType , IList ExternalResourceReferenceThe expanded map of the external resource references referenced by the element.

Exception | Condition |
---|---|
InvalidOperationException | This Element does not use any external resource. |

The value includes all external resource references under the type. Use this API for an element which has multiple external resource references under a specified type, e.g., AppearanceAssetElement. See also: [!:Autodesk::Revit::DB::Element::getExternalResourceReferences] .