SetCellCalculatedValue Method (Int32, Int32, TableCellCalculatedValueData)


Allows the caller to set the calculated value for a specified cell

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellCalculatedValue(
	int nRow,
	int nCol,
	TableCellCalculatedValueData pCalcValue
)
Visual Basic
Public Sub SetCellCalculatedValue ( _
	nRow As Integer, _
	nCol As Integer, _
	pCalcValue As TableCellCalculatedValueData _
)
Visual C++
public:
void SetCellCalculatedValue(
	int nRow, 
	int nCol, 
	TableCellCalculatedValueData^ pCalcValue
)

Parameters

nRow
Type: SystemInt32
nCol
Type: SystemInt32
pCalcValue
Type: Autodesk.Revit.DBTableCellCalculatedValueData

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The given row number nRow is invalid. -or- The given column number nCol is invalid.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This operation is forbidden for cells in standard schedule header sections. -or- This operation is forbidden for cells in standard schedule body sections.

See Also