IsAllowedDimensionStyleType Method


Only Linear and LinearFixed dimension style types are allowed for new MultiReferenceAnnotations.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public bool IsAllowedDimensionStyleType(
	DimensionStyleType dimensionStyleType
)
Visual Basic
Public Function IsAllowedDimensionStyleType ( _
	dimensionStyleType As DimensionStyleType _
) As Boolean
Visual C++
public:
bool IsAllowedDimensionStyleType(
	DimensionStyleType dimensionStyleType
)

Parameters

dimensionStyleType
Type: Autodesk.Revit.DBDimensionStyleType
The dimension style type to test.

Return Value

True if the type is allowed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also