IndexTriangle Class


A triangle primitive consisting of three indices.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public class IndexTriangle : IndexPrimitive
Visual Basic
Public Class IndexTriangle _
	Inherits IndexPrimitive
Visual C++
public ref class IndexTriangle : public IndexPrimitive

Remarks

Indices of a triangle's vertices can be listed in either the clockwise or counterclockwise winding order, according to the triangle's orientation in space. A DirectContext3D triangle faces the viewer if its vertices are in counterclockwise order from the viewer's point of view.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DB.DirectContext3DIndexPrimitive
    Autodesk.Revit.DB.DirectContext3DIndexTriangle

See Also