IndexTriangle Class


Index Triangle Class

A triangle primitive consisting of three indices.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D IndexPrimitive
Autodesk.Revit.DB.DirectContext3D IndexTriangle

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IndexTriangle : IndexPrimitive

The IndexTriangle type exposes the following members.

Constructors
Name Description
Public method IndexTriangle Constructs the triangle primitive.
Top
Properties
Name Description
Public property Index0 The index of the triangle's first vertex.
Public property Index1 The index of the triangle's second vertex.
Public property Index2 The index of the triangle's third vertex.
Top
Methods
Name Description
Public method Static member GetSizeInShortInts Gets the amount of storage that the primitive takes up in a buffer, measured in short integers.
Top
Remarks
Indices of a triangle's vertices can be listed in either the clockwise or counterclockwise winding order, according to the triangle's orientation in space. A DirectContext3D triangle faces the viewer if its vertices are in counterclockwise order from the viewer's point of view.
See Also