SetCellType Method (Int32, CellType)


Sets a column's cell type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetCellType(
	int nCol,
	CellType type
)
Visual Basic
Public Sub SetCellType ( _
	nCol As Integer, _
	type As CellType _
)
Visual C++
public:
void SetCellType(
	int nCol, 
	CellType type
)

Parameters

nCol
Type: SystemInt32
type
Type: Autodesk.Revit.DBCellType

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException A CellType.CustomField can't be set. -or- The given column number nCol is invalid.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This operation is forbidden for cells in standard schedule body sections.

See Also