SetCellType Method (Int32, CellType)


Table Section Data Set Cell Type(Int 32, Cell Type) Method

Sets a column's cell type

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCellType(
	int nCol,
	CellType type
)

Parameters

nCol Int32
type CellType
Exceptions
Exception Condition
ArgumentException A CellType.CustomField can't be set. -or- The given column number nCol is invalid.
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException This operation is forbidden for cells in standard schedule body sections.
See Also