Create Method


Creates a new instance of an Analytical Member within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public static AnalyticalMember Create(
	Document aDoc,
	Curve curve
)
Visual Basic
Public Shared Function Create ( _
	aDoc As Document, _
	curve As Curve _
) As AnalyticalMember
Visual C++
public:
static AnalyticalMember^ Create(
	Document^ aDoc, 
	Curve^ curve
)

Parameters

aDoc
Type: Autodesk.Revit.DBDocument
A Revit document.
curve
Type: Autodesk.Revit.DBCurve
Curve of the analytical member.

Return Value

The newly created Analytical Member instance.

Remarks

The curve must be bounded. The curve can be:
  • Line
  • Arc
  • Ellipse

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input curve is not bound. -or- The provided curve is not supported.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also