Create Method


Analytical Member Create Method

Creates a new instance of an Analytical Member within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static AnalyticalMember Create(
	Document aDoc,
	Curve curve
)

Parameters

aDoc Document
A Revit document.
curve Curve
Curve of the analytical member.

Return Value

AnalyticalMember
The newly created Analytical Member instance.
Exceptions
Exception Condition
ArgumentException The input curve is not bound. -or- The provided curve is not supported.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
The curve must be bounded. The curve can be:
  • Line
  • Arc
  • Ellipse
See Also