Obtains ownership for the current user of as many specified worksets as possible.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document containing the worksets.
- worksetsToCheckout
- Type: System.Collections.GenericICollectionWorksetId
The ids of the worksets to attempt to check out.
Return Value
The ids of all specified worksets that are now owned, including all that were owned prior to the function call.Remarks
For best performance, check out all worksets in one big call, rather than many small calls.
When there comes a contention error when locking the central model, this API would wait and retry endlessly until getting the lock of the central model.
Examples

void CheckoutAllViewWorksets(Document doc)
{
FilteredWorksetCollector collector = new FilteredWorksetCollector(doc);
// find all view worksets
collector.OfKind(WorksetKind.ViewWorkset);
ICollection<WorksetId> viewworksets = collector.ToWorksetIds();
ICollection<WorksetId> checkoutworksets = WorksharingUtils.CheckoutWorksets(doc, viewworksets);
TaskDialog.Show("Checked out worksets", "Number of worksets checked out: " + checkoutworksets.Count);
}

Private Sub CheckoutAllViewWorksets(doc As Document)
Dim collector As New FilteredWorksetCollector(doc)
' find all view worksets
collector.OfKind(WorksetKind.ViewWorkset)
Dim viewworksets As ICollection(Of WorksetId) = collector.ToWorksetIds()
Dim checkoutworksets As ICollection(Of WorksetId) = WorksharingUtils.CheckoutWorksets(doc, viewworksets)
TaskDialog.Show("Checked out worksets", "Number of worksets checked out: " + checkoutworksets.Count)
End Sub
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | document is not a workshared document. -or- document is not a primary document, it is a linked document. -or- document is read-only: It cannot be modified. -or- document has an open editing transaction and is accepting changes. -or- There are one or more ids with no corresponding workset. -or- Saving is not allowed in the current application mode. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsCentralFileCommunicationException | The file-based central model could not be reached, e.g. the network is down or the file server is down. |
Autodesk.Revit.ExceptionsCentralModelAccessDeniedException | Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance. |
Autodesk.Revit.ExceptionsCentralModelContentionException | The central model are locked by another client. |
Autodesk.Revit.ExceptionsCentralModelException | The central model is overwritten by other user. -or- The central model is missing. -or- An internal error happened on the central model, please contact the server administrator. |
Autodesk.Revit.ExceptionsCentralModelVersionArchivedException | Last central version merged into the local model has been archived in the central model. This exception could only be thrown from cloud models. |
Autodesk.Revit.ExceptionsInvalidOperationException | Operation is not permitted when there is any open sub-transaction, transaction, or transaction group. |
Autodesk.Revit.ExceptionsRevitServerCommunicationException | The server-based central model could not be accessed because of a network communication error. |
Autodesk.Revit.ExceptionsRevitServerInternalException | An internal error happened on the server, please contact the server administrator. |