CreateKeySchedule Method


Create a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static ViewSchedule CreateKeySchedule(
	Document document,
	ElementId categoryId
)
Visual Basic
Public Shared Function CreateKeySchedule ( _
	document As Document, _
	categoryId As ElementId _
) As ViewSchedule
Visual C++
public:
static ViewSchedule^ CreateKeySchedule(
	Document^ document, 
	ElementId^ categoryId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to which the new schedule will be added.
categoryId
Type: Autodesk.Revit.DBElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

The newly created schedule.

Remarks

A key schedule displays abstract "key" elements that can be used to populate parameters of ordinary model elements.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException document is not a project document. -or- categoryId is not a valid category for a key schedule.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also