CreateKeySchedule Method


View Schedule Create Key Schedule Method

Create a key schedule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ViewSchedule CreateKeySchedule(
	Document document,
	ElementId categoryId
)

Parameters

document Document
The document to which the new schedule will be added.
categoryId ElementId
The ID of the category of elements that the schedule's keys will be associated with.

Return Value

ViewSchedule
The newly created schedule.
Exceptions
Exception Condition
ArgumentException document is not a project document. -or- categoryId is not a valid category for a key schedule.
ArgumentNullException A non-optional argument was null
ModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
ModificationOutsideTransactionException The document has no open transaction.
Remarks
A key schedule displays abstract "key" elements that can be used to populate parameters of ordinary model elements.
See Also