Creates a new instance of a mechanical system and adds it to the document.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADocument
- Type: Autodesk.Revit.DBDocument
The document where the element will be created and added.
- typeId
- Type: Autodesk.Revit.DBElementId
The identifier of this mechanical system element's type.
- name
- Type: SystemString
The name of the mechanical system to be created.
Return Value
The newly created mechanical system element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The typeId is not an element id for a valid mechanical system type. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |