Mechanical |
Creates a new instance of a mechanical system and adds it to the document.
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static MechanicalSystem Create(
Document ADocument,
ElementId typeId,
string name
)
Parameters
- ADocument Document
- The document where the element will be created and added.
- typeId ElementId
- The identifier of this mechanical system element's type.
- name String
- The name of the mechanical system to be created.
Return Value
MechanicalSystemThe newly created mechanical system element.

Exception | Condition |
---|---|
ArgumentException | The typeId is not an element id for a valid mechanical system type. |
ArgumentNullException | A non-optional argument was null |