Sets the parameter to a new element id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- value
- Type: Autodesk.Revit.DBElementId
The new element id to which the parameter is to be set.
Return Value
The Set method will return True if the parameter was successfully set to the new value, otherwise false.Remarks
You should only use this method if the StorageType property reports the type of the parameter as an ElementId.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | The parameter is read-only. |