Set Method (ElementId)


Parameter Set(Element Id) Method

Sets the parameter to a new element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Set(
	ElementId value
)

Parameters

value ElementId
The new element id to which the parameter is to be set.

Return Value

Boolean
The Set method will return True if the parameter was successfully set to the new value, otherwise false.
Exceptions
Exception Condition
InvalidOperationException The parameter is read-only.
Remarks
You should only use this method if the StorageType property reports the type of the parameter as an ElementId.
See Also