GetRelativeLocalPlacementOffsetTransform Method


Obtains the relative transform between two IfcLocalPlacement handles.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static Transform GetRelativeLocalPlacementOffsetTransform(
	IFCAnyHandle originalPlacement,
	IFCAnyHandle relativePlacement
)
Visual Basic
Public Shared Function GetRelativeLocalPlacementOffsetTransform ( _
	originalPlacement As IFCAnyHandle, _
	relativePlacement As IFCAnyHandle _
) As Transform
Visual C++
public:
static Transform^ GetRelativeLocalPlacementOffsetTransform(
	IFCAnyHandle^ originalPlacement, 
	IFCAnyHandle^ relativePlacement
)

Parameters

originalPlacement
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The original placement from which the result transforms coordinates and directions.
relativePlacement
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The relative placement to which the result transforms coordinates and directions.

Return Value

The transform from the original placement to the new placement.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also