GetRelativeLocalPlacementOffsetTransform Method


Exporter IFCUtils Get Relative Local Placement Offset Transform Method

Obtains the relative transform between two IfcLocalPlacement handles.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Transform GetRelativeLocalPlacementOffsetTransform(
	IFCAnyHandle originalPlacement,
	IFCAnyHandle relativePlacement
)

Parameters

originalPlacement IFCAnyHandle
The original placement from which the result transforms coordinates and directions.
relativePlacement IFCAnyHandle
The relative placement to which the result transforms coordinates and directions.

Return Value

Transform
The transform from the original placement to the new placement.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also