ExportToPCF Method


Exports a list of fabrication parts into PCF format.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public static void ExportToPCF(
	Document document,
	IList<ElementId> ids,
	string filename
)
Visual Basic
Public Shared Sub ExportToPCF ( _
	document As Document, _
	ids As IList(Of ElementId), _
	filename As String _
)
Visual C++
public:
static void ExportToPCF(
	Document^ document, 
	IList<ElementId^>^ ids, 
	String^ filename
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
ids
Type: System.Collections.GenericIListElementId
An array of FabricationPart element identifiers. Non-fabrication parts are ignored.
filename
Type: SystemString
The name given to the output file.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Fabrication configuration is missing.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also