ExportToPCF Method


Fabrication Utils Export To PCF Method

Exports a list of fabrication parts into PCF format.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void ExportToPCF(
	Document document,
	IList<ElementId> ids,
	string filename
)

Parameters

document Document
The document.
ids IList ElementId
An array of FabricationPart element identifiers. Non-fabrication parts are ignored.
filename String
The name given to the output file.
Exceptions
Exception Condition
ArgumentException Fabrication configuration is missing.
ArgumentNullException A non-optional argument was null
See Also