Intersect Method (Curve)


Calculates the intersection of the specified curve with this face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SetComparisonResult Intersect(
	Curve curve
)
Visual Basic
Public Function Intersect ( _
	curve As Curve _
) As SetComparisonResult
Visual C++
public:
SetComparisonResult Intersect(
	Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DBCurve
The specified curve to intersect with this face.

Return Value

  • SetComparisonResult.Overlap - One or more intersections were encountered.
  • SetComparisonResult.Subset - The curve is coincident with the surface.
  • SetComparisonResult.Disjoint - There is no intersection found.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException The curve is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException The intersection calculation fails.

See Also