Face Intersect(Curve) Method |
Calculates the intersection of the specified curve with this face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- curve Curve
- The specified curve to intersect with this face.
Return Value
SetComparisonResult- SetComparisonResult.Overlap - One or more intersections were encountered.
- SetComparisonResult.Subset - The curve is coincident with the surface.
- SetComparisonResult.Disjoint - There is no intersection found.

Exception | Condition |
---|---|
ArgumentNullException | The curve is . |
InvalidOperationException | The intersection calculation fails. |