IsViewIdValidForViewport Method


Verifies that the Viewport can change it's view id to the input %viewId%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public bool IsViewIdValidForViewport(
	ElementId viewId
)
Visual Basic
Public Function IsViewIdValidForViewport ( _
	viewId As ElementId _
) As Boolean
Visual C++
public:
bool IsViewIdValidForViewport(
	ElementId^ viewId
)

Parameters

viewId
Type: Autodesk.Revit.DBElementId
The view which will be checked to see if it can be applied to Viewport.

Return Value

True if the %viewId% is valid for the viewport, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also