IsViewIdValidForViewport Method


Viewport Is View Id Valid For Viewport Method

Verifies that the Viewport can change it's view id to the input %viewId%.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsViewIdValidForViewport(
	ElementId viewId
)

Parameters

viewId ElementId
The view which will be checked to see if it can be applied to Viewport.

Return Value

Boolean
True if the %viewId% is valid for the viewport, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also