GetGBXMLDocumentId Method


Retrieves the GUID representing this document in exported gbXML files.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static Guid GetGBXMLDocumentId(
	Document document
)
Visual Basic
Public Shared Function GetGBXMLDocumentId ( _
	document As Document _
) As Guid
Visual C++
public:
static Guid GetGBXMLDocumentId(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.

Return Value

The value of the GUID representing this document in gbXML export.

Remarks

This id can be used to cross-reference different gbXML exports from the same document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also