TryParse Method (Units, ForgeTypeId, String, ValueParsingOptions, Double, String)


Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static bool TryParse(
	Units units,
	ForgeTypeId specTypeId,
	string stringToParse,
	ValueParsingOptions valueParsingOptions,
	out double value,
	out string message
)
Visual Basic
Public Shared Function TryParse ( _
	units As Units, _
	specTypeId As ForgeTypeId, _
	stringToParse As String, _
	valueParsingOptions As ValueParsingOptions, _
	<OutAttribute> ByRef value As Double, _
	<OutAttribute> ByRef message As String _
) As Boolean
Visual C++
public:
static bool TryParse(
	Units^ units, 
	ForgeTypeId^ specTypeId, 
	String^ stringToParse, 
	ValueParsingOptions^ valueParsingOptions, 
	[OutAttribute] double% value, 
	[OutAttribute] String^% message
)

Parameters

units
Type: Autodesk.Revit.DBUnits
The units formatting settings, typically obtained from Document.GetUnits().
specTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the target spec for the value.
stringToParse
Type: SystemString
The string to parse.
valueParsingOptions
Type: Autodesk.Revit.DBValueParsingOptions
Additional parsing options.
value
Type: SystemDouble%
The parsed value. Ignore this value if the function returns false.
message
Type: SystemString%
A localized message that, if the parsing fails, explains the reason for failure.

Return Value

True if the string can be parsed, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The unit in the FormatOptions in valueParsingOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also