TryParse Method (Units, ForgeTypeId, String, ValueParsingOptions, Double, String)


Unit Format Utils Try Parse(Units, Forge Type Id, String, Value Parsing Options, Double , String ) Method

Parses a formatted string into a number with units if possible.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool TryParse(
	Units units,
	ForgeTypeId specTypeId,
	string stringToParse,
	ValueParsingOptions valueParsingOptions,
	out double value,
	out string message
)

Parameters

units Units
The units formatting settings, typically obtained from Document.GetUnits() .
specTypeId ForgeTypeId
Identifier of the target spec for the value.
stringToParse String
The string to parse.
valueParsingOptions ValueParsingOptions
Additional parsing options.
value Double
The parsed value. Ignore this value if the function returns false.
message String
A localized message that, if the parsing fails, explains the reason for failure.

Return Value

Boolean
True if the string can be parsed, false otherwise.
Exceptions
Exception Condition
ArgumentException specTypeId is not a measurable spec identifier. See UnitUtils.IsMeasurableSpec(ForgeTypeId). -or- The unit in the FormatOptions in valueParsingOptions is not a valid unit for specTypeId. See UnitUtils.IsValidUnit(ForgeTypeId, ForgeTypeId) and UnitUtils.GetValidUnits(ForgeTypeId).
ArgumentNullException A non-optional argument was null
See Also