Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- wallHeight
- Type: SystemDouble
The height of the wall.
- distAboveBase
- Type: SystemDouble
The distance from the base of the wall at which to take the section. If distAboveBase < 0, then internally distAboveBase = 0 is used. If distAboveBase > wallHeight, then internally distAboveBase = wallHeight is used.
Return Value
A simple CompoundStructure representing a series of parallel layers.Remarks
If IsVerticallyCompound is false, the output is a copy of this CompoundStructure.