Compound |
Takes a horizontal slice through a sample wall to which this CompoundStructure is applied and returns a simple compound structure which describes that slice, i.e. a series of parallel layers.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public CompoundStructure GetSimpleCompoundStructure(
double wallHeight,
double distAboveBase
)
Parameters
- wallHeight Double
- The height of the wall.
- distAboveBase Double
- The distance from the base of the wall at which to take the section. If distAboveBase < 0, then internally distAboveBase = 0 is used. If distAboveBase > wallHeight, then internally distAboveBase = wallHeight is used.
Return Value
CompoundStructureA simple CompoundStructure representing a series of parallel layers.

If IsVerticallyCompound is false, the output is a copy of this CompoundStructure.