CanSplitStraight Method (XYZ)


Validates if the straight can be split into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public bool CanSplitStraight(
	XYZ position
)
Visual Basic
Public Function CanSplitStraight ( _
	position As XYZ _
) As Boolean
Visual C++
public:
bool CanSplitStraight(
	XYZ^ position
)

Parameters

position
Type: Autodesk.Revit.DBXYZ
The position to split in the straight.

Return Value

Returns true if valid otherwise false if the straight cannot be split.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also