CanSplitStraight Method (XYZ)


Fabrication Part Can Split Straight Method

Validates if the straight can be split into two at the passed in point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanSplitStraight(
	XYZ position
)

Parameters

position XYZ
The position to split in the straight.

Return Value

Boolean
Returns true if valid otherwise false if the straight cannot be split.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also