AdjustForCyclicalBounds Method


Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public RepeaterCoordinates AdjustForCyclicalBounds(
	RepeaterCoordinates coordinates
)
Visual Basic
Public Function AdjustForCyclicalBounds ( _
	coordinates As RepeaterCoordinates _
) As RepeaterCoordinates
Visual C++
public:
RepeaterCoordinates^ AdjustForCyclicalBounds(
	RepeaterCoordinates^ coordinates
)

Parameters

coordinates
Type: Autodesk.Revit.DBRepeaterCoordinates
The coordinates.

Return Value

The adjusted coordinates.

Remarks

The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The coordinates coordinates have incompatible number of dimensions.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The bounds must have at least one dimension.

See Also