Repeater |
Shifts the input coordinates in the cyclical dimensions so that they fall in the [lower bounds, upper bounds] range.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- coordinates RepeaterCoordinates
- The coordinates.
Return Value
RepeaterCoordinatesThe adjusted coordinates.

Exception | Condition |
---|---|
ArgumentException | The coordinates coordinates have incompatible number of dimensions. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The bounds must have at least one dimension. |

The coordinates must have the same number of dimensions as the bounds. This method does not apply to zero dimensional bounds.