GetCustomFieldProperties Method


Gets an instance of ICustomFieldProperties which represents the properties of this field.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ICustomFieldProperties GetCustomFieldProperties()
Visual Basic
Public Function GetCustomFieldProperties As ICustomFieldProperties
Visual C++
public:
ICustomFieldProperties^ GetCustomFieldProperties()

Return Value

Returns an instance of ICustomFieldProperties.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Can't obtain the properties from a CustomFieldData of a SchedulableField (which is not added to a schedule).

See Also