Verify the uniqueness of the name among all analysis display style elements of the document.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
Document in which name uniqueness is verified.
- name
- Type: SystemString
Name to verify uniqueness of.
- excludedElement
- Type: Autodesk.Revit.DB.AnalysisAnalysisDisplayStyle
Element to be excluded from uniqueness verification (for renaming of an existing element).
Return Value
True if name is unique, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |