IsNameUnique Method


Analysis Display Style Is Name Unique Method

Verify the uniqueness of the name among all analysis display style elements of the document.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsNameUnique(
	Document document,
	string name,
	AnalysisDisplayStyle excludedElement
)

Parameters

document Document
Document in which name uniqueness is verified.
name String
Name to verify uniqueness of.
excludedElement AnalysisDisplayStyle
Element to be excluded from uniqueness verification (for renaming of an existing element).

Return Value

Boolean
True if name is unique, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also