GetNodeByIndex Method


Gets the specified analytical node.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public MEPAnalyticalNode GetNodeByIndex(
	int index
)
Visual Basic
Public Function GetNodeByIndex ( _
	index As Integer _
) As MEPAnalyticalNode
Visual C++
public:
MEPAnalyticalNode^ GetNodeByIndex(
	int index
)

Parameters

index
Type: SystemInt32
The node index number by their storing sequence, starting from 0.

Return Value

The returned analytical node.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The index must range from 0 to GetNumberOfNodes()-1.

See Also