GetNodeByIndex Method


MEPAnalytical Model Data Get Node By Index Method

Gets the specified analytical node.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public MEPAnalyticalNode GetNodeByIndex(
	int index
)

Parameters

index Int32
The node index number by their storing sequence, starting from 0.

Return Value

MEPAnalyticalNode
The returned analytical node.
Exceptions
Exception Condition
ArgumentOutOfRangeException The index must range from 0 to GetNumberOfNodes()-1.
See Also