Append Method


Append the curve to this loop.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void Append(
	Curve curve
)
Visual Basic
Public Sub Append ( _
	curve As Curve _
)
Visual C++
public:
void Append(
	Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DBCurve
The curve.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input curve points to a helical curve and is not supported for this operation. -or- Throws if the input curve makes the loop not contiguous.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also