SetSegmentAs180DegreeBend Method (Int32)


Indicates that a segment is a "virtual" segment introduced to describe a 180-degree bend. The radius of the bend will be taken from the Bar Type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SetSegmentAs180DegreeBend(
	int iSegment
)
Visual Basic
Public Sub SetSegmentAs180DegreeBend ( _
	iSegment As Integer _
)
Visual C++
public:
void SetSegmentAs180DegreeBend(
	int iSegment
)

Parameters

iSegment
Type: SystemInt32
Index of the segment (0 to NumberOfSegments - 1).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException iSegment is not between 0 and NumberOfSegments.

See Also